Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 14, 2025 - 17:00 PST
Scheduled
MAP Growth, PL Online, MAP Reading Fluency, and NWEA State Assessments won't be available Fri, Feb 14 at 5:00 p.m. PST to Sat, Feb 15 at 10:00 a.m. PST due to scheduled system maintenance.
Because we want you to have access to any reports you may request, we highly suggest running your last report two hours prior to the scheduled system maintenance start time. This will help to ensure that the system completes your report before the downtime begins.
Posted Feb 10, 2025 - 16:41 PST
This scheduled maintenance affected: MAP Growth (MAP Growth Student Testing, MAP Growth Admin User Interface (MARC), MAP Growth Reports User Interface, Instructional Connections), NWEA State Assessments (Student Testing, Manage Online Testing, Reports), MAP Reading Fluency (MAP Reading Fluency Student Testing, MAP Reading Fluency Educator Dashboard, Coach), and Professional Learning Online, Start Page.