NWEA MAP Growth

Incident Report for NWEA

Resolved

MAP Growth has operated normally since 12:45PM ET. After a period of monitoring as a precaution, this incident is now resolved.

Our investigation indicates this issue is likely related to a broader internet instability event that impacted multiple regions in the US.
Posted May 14, 2025 - 14:15 PDT

Update

Some users experienced Map Growth access issues between 12:15PM ET and 12:45Pm ET today. Service on MAP Growth returned to normal at 12:45PM ET and our teams continue to monitor performance as a precaution.
Posted May 14, 2025 - 11:15 PDT

Monitoring

Our teams are monitoring performance on MAP Growth.
Posted May 14, 2025 - 10:16 PDT

Investigating

We are investigating a possible issue impacting MAP Growth assessment and additional updates will be posted here as soon as more information is available. Thank you for your patience.
Posted May 14, 2025 - 10:12 PDT
This incident affected: MAP Growth (MAP Growth Student Testing, MAP Growth Admin User Interface (MARC)).