Issues with K-2 Skills Checklist and Screener reports
Incident Report for NWEA
Resolved
NWEA Engineers have implemented a solution and this issue is resolved. If you continue to experience issues with MAP Growth reports, please contact technical support.
Posted Nov 01, 2023 - 19:02 PDT
Investigating
We have received reports of partners not being able to access K-2 Skills Checklist and Screener reports. NWEA engineers are currently investigating a potential solution. We will post additional information when it becomes available.
Posted Nov 01, 2023 - 09:00 PDT
This incident affected: MAP Growth (MAP Growth Reports User Interface).