Delays Impacting District, School, Class Profiles and Family Report

Incident Report for NWEA

Resolved

Test events from May 14 are now populating in the impacted reports. This incident has been resolved.
Posted May 15, 2026 - 14:12 PDT

Identified

We have identified an issue causing delays with data from tests completed 5/14 on the following reports:

Class Profile
School Profile
District Profile
Family Report

All other reports remain available and are functioning normally.
Posted May 15, 2026 - 08:29 PDT
This incident affected: MAP Growth (MAP Growth Reports User Interface).