Data displayed on MAP Growth Profile reports

Incident Report for NWEA

Resolved

Impacted reports are displaying the most current data. This incident is resolved.
Posted Dec 10, 2025 - 14:54 PST

Identified

We've addressed the cause of this incident. Current data will be displayed on the impacted reports no later than tomorrow morning. Thank you for your patience.
Posted Dec 10, 2025 - 08:14 PST

Investigating

We are currently investigating an issue where some MAP Growth reports are experiencing a delay in getting the most current data. Those impacted are Class Profile, School Profile, District Profile, and Batch Print for Family Report.
Posted Dec 10, 2025 - 07:15 PST
This incident affected: MAP Growth (MAP Growth Reports User Interface).