Some NWEA applications impacted by Cloudflare outage

Incident Report for NWEA

Resolved

NWEA applications have remained stable and available during the monitoring period and Cloudflare has indicated that they are seeing errors and latency rates return to normal levels. This incident is now resolved.
Posted Nov 18, 2025 - 09:18 PST

Monitoring

Cloudflare has indicated that the incident is resolved and we're seeing NWEA applications are available. We will continue to monitor.
Posted Nov 18, 2025 - 07:02 PST

Investigating

Some NWEA applications are being impacted by the Cloudflare outage this morning. We're monitoring the situation closely and will post more information as soon as possible. You can follow this incident for ongoing updates.
Posted Nov 18, 2025 - 06:44 PST
This incident affected: MAP Growth (MAP Growth Student Testing, MAP Growth Admin User Interface (MARC), MAP Growth Reports User Interface) and MAP Reading Fluency (MAP Reading Fluency Student Testing, MAP Reading Fluency Educator Dashboard).