MAP Growth Testing

Incident Report for NWEA

Update

We deployed an improvement overnight and have continued to see stable performance for MAP Growth today. No interruptions have been detected since Wednesday morning. As a precaution, we will continue monitoring closely over the weekend.
Posted Sep 12, 2025 - 13:28 PDT

Update

No interruptions have been detected for MAP Growth today and performance has remained normal since yesterday morning. As a precaution, we will continue monitoring performance closely today and tomorrow. Thank you for your continued patience.
Posted Sep 11, 2025 - 12:49 PDT

Update

MAP Growth performance has remained stable today, and we have not observed any additional testing or proctor errors. As a precaution, we will continue monitoring performance closely and working to address the underlying cause. Thank you for your continued patience.
Posted Sep 10, 2025 - 20:01 PDT

Update

MAP Growth experienced a brief interruption yesterday (9/9/25) between 6:30AM – 6:45AM PT and again today (9/10/25) between 7:00AM – 7:20AM PT. During this time, some students may have seen a message indicating an assessment item was taking too long and some proctors may have experienced slow loading times.

Performance is stable and our teams are closely monitoring while working to address the underlying cause. Thank you for your patience.
Posted Sep 10, 2025 - 10:08 PDT

Monitoring

Please be advised we have received reports that some users may have experienced error messages when accessing MAP Growth this morning between 6:30AM PT and 6:45AM PT. Operations have stabilized and we continue to investigate the cause. Thank you for your patience.
Posted Sep 09, 2025 - 07:51 PDT
This incident affects: MAP Growth (MAP Growth Student Testing).