Thank you for your patience as we've worked though delays in delivering data export requests. Processing is now complete.
Posted Feb 21, 2025 - 14:05 PST
Update
Data export requests continue to process by the order in which they were received and we are actively monitoring progress. We will update this page either when processing is complete or by Friday at 5 PM ET, whichever comes first.
Posted Feb 20, 2025 - 14:03 PST
Monitoring
A fix was deployed as planned and data export requests are processing in the order in which they were received. We will continue to monitor the processing of these requests throughout the day today. Another update will be posted by 5 PM ET.
Posted Feb 20, 2025 - 07:49 PST
Identified
Engineering teams have identified a potential fix to address data export delays, which is planned for release this evening. We will monitor the release and provide another update tomorrow by 12 PM ET.
Posted Feb 19, 2025 - 13:59 PST
Update
Engineers are working diligently to address possible delays with data exports. Thank you for your patience. Our next update will be posted by 5 PM ET.
Posted Feb 19, 2025 - 10:59 PST
Update
We are continuing to investigate and monitor possible delays with data exports. This page will be updated again no later than 2 PM ET.
Posted Feb 19, 2025 - 07:58 PST
Update
We are continuing to monitor possible delays with data exports. This page will be updated as more information becomes available.
Posted Feb 18, 2025 - 12:54 PST
Investigating
We are aware of possible delays with data exports and engineering teams are currently investigating this issue. We will update this page again as more information becomes available. We apologize for any inconvenience this may cause.
Posted Feb 18, 2025 - 10:03 PST
This incident affected: MAP Growth (MAP Growth Reports User Interface).