MAP Growth has continued to operate normally, with no recurrence of the login or item‑loading delays observed over multiple consecutive days. Following actions taken last week and a period of heightened monitoring, this incident is now considered resolved.
We will continue to monitor platform performance and will communicate if any related issues re‑emerge. Thank you for your patience.
Posted May 20, 2026 - 10:29 PDT
Monitoring
MAP Growth continues to operate normally, with no recurrence of the login or item‑loading delays over multiple consecutive days. Based on the sustained stability observed since Friday, we are moving this incident into a monitoring state. We will continue heightened monitoring and will provide additional updates if conditions change.
Posted May 19, 2026 - 09:48 PDT
Update
MAP Growth has continued to operate normally, and we have not observed a return of the login or item‑loading delays for a second consecutive day. Teams took action Friday evening and we are encouraged by the sustained stability. We will continue wth heightened monitoring.
Posted May 18, 2026 - 10:42 PDT
Update
MAP Growth has continued to perform normally. We are maintaining heightened monitoring while our teams continue analysis to better understand the underlying cause. We will share additional updates if conditions change.
Posted May 14, 2026 - 11:52 PDT
Update
Performance has remained stable today, and we are not currently observing the issues associated with this incident. The team continues to actively monitor the platform while we validate ongoing stability. Thank you for your patience.
Posted May 14, 2026 - 08:20 PDT
Update
We continue to investigate reports of login and item-loading delays during MAP Growth test sessions and have narrowed the issue to a potential cause. Some users may still experience delays, though testing is generally able to proceed. Work is ongoing to resolve the issue.
Posted May 13, 2026 - 14:48 PDT
Update
Our investigation into this issue continues. Thank you for your patience and we apologize for any inconvenience.
Posted May 13, 2026 - 09:46 PDT
Update
We are seeing some recurrence of issues with MAP Growth again today and are continuing to investigate.
Posted May 13, 2026 - 07:54 PDT
Update
MAP Growth performance has stabilized. We’re continuing to investigate potential causes and closely monitoring apps and services. You can continue to check this page for updates and/or click on the "SUBSCRIBE TO UPDATES" button above to receive updates via email or text.
Posted May 12, 2026 - 13:16 PDT
Update
We are continuing to investigate this issue. Thank you for your patience.
Posted May 12, 2026 - 11:13 PDT
Investigating
We are currently investigating reports of potential delays loading MAP Growth assessments and items. This page will be updated as we know more.
Posted May 12, 2026 - 10:17 PDT
This incident affected: MAP Growth (MAP Growth Student Testing).