The MAP Growth Start page for Administrators has operated normally since Thursday, April 24, 2025, at 9:22AM ET. After monitoring yesterday and this morning, we are confident this issue has been resolved.
Posted Apr 25, 2025 - 07:44 PDT
Update
Performance in MAP Growth continues to operate normally with no impact for educators or students. As a precaution this incident will remain in the state of monitoring overnight and an update will be provided tomorrow.
Posted Apr 24, 2025 - 14:15 PDT
Update
Performance in MAP Growth continues to operate normally with no impact for educators or students. As a precaution this incident will remain in the state of monitoring.
Posted Apr 24, 2025 - 10:16 PDT
Monitoring
Please be advised that the MAP Growth Start page experienced a brief service interruption this morning between 8:38AM ET and 9:22AM ET. Our teams were able to resolve this issue and operations are normal.
Our teams will continue monitoring performance today as a precaution. We apologize for any inconvenience this issue may cause.
Posted Apr 24, 2025 - 06:50 PDT
This incident affected: MAP Growth (MAP Growth Admin User Interface (MARC)).