NWEA Contact Center Phone System Intermittent Connection Issues
Incident Report for NWEA
Resolved
The issue that was impacting connectivity for the contact center phone system has been resolved. All systems are operational and partners can reach the Help Center via phone, chat, and email.
Posted 13 days ago. Apr 08, 2019 - 10:39 PDT
Monitoring
The NWEA contact center phone system is experiencing intermittent interruptions and as a result, partners may experience challenges reaching Help Center staff. If you have this issue, we recommend that you utilize chat and email to reach the Help Center at this time. Testing is not impacted by this issue. We will update this page by 5:00PM PT/8:00PM ET.
Posted 13 days ago. Apr 08, 2019 - 09:34 PDT
This incident affected: NWEA.org.