Partner Support Portal Login Problems
Incident Report for NWEA
Resolved
All issues with the NWEA Partner Support Portal have been resolved and the system is once again fully operational. We apologize for any inconvenience.
Posted Feb 11, 2020 - 15:29 PST
Update
Login issue has been identified to be with our hosting provider and are working with them to resolve the problem. We will keep you posted on further updates as they become available.
Posted Feb 11, 2020 - 02:57 PST
Identified
The NWEA Partner Support Portal is experiencing login issues to the site and as a result, partners may experience challenges opening\reviewing support cases or viewing articles. Testing is not impacted by this issue.  We will update this page by 3:00AM PT/6:00AM ET.
Posted Feb 11, 2020 - 00:57 PST
This incident affected: NWEA Connection (Partner Support Portal).