MAP Growth, MAP Skills and Summative Logins Unavailable
Incident Report for NWEA
Resolved
This incident has been resolved.
Posted Jun 29, 2020 - 12:05 PDT
Update
Engineers have identified and corrected the issue. All systems should now be available for use. We apologize for any inconvenience you may have experienced.
Posted Jun 29, 2020 - 12:05 PDT
Update
Engineers are continuing to investigate this issue. We will post an update within 30 minutes.
Posted Jun 29, 2020 - 11:56 PDT
Investigating
Partners and students are experiencing an error when trying to log into or use MAP Growth and MAP Skills. Engineers are currently investigating and working to resolve the issue.

We recommend you temporarily refrain from testing. We apologize for the inconvenience and will update this page within 30 minutes.
Posted Jun 29, 2020 - 11:29 PDT
This incident affected: MAP Skills (MAP Skills Student Testing, MAP Skills Student Dashboard, MAP Skills Educator Dashboard) and MAP Growth (MAP Growth Student Testing, MAP Growth Admin User Interface (MARC), MAP Growth Reports User Interface).